You might have noticed from your dashboard that WordPress released yesterday 2.5.1 which they say has a “very important security fix”. They haven’t disclosed exactly what the fix is about.

If you have already installed 2.5, then you better rush with upgrading to 2.5.1.

I personally didn’t install 2.5 yet, because I tested with it on my local laptop, and I noticed my installation didn’t work well with IE.

This fix is addressing IE and performance issues as well as the security fix.

I will download and test (both FireFox and IE), and if it works fine I will upgrade.

To find more about WordPress installation announcement and files, click here.

To check some WordPress security vulnerability statistics by Technorati, click here.

Regards.