WordPress version 3.0.4 is out and is rated as “critical”, meaning you should make the effort to upgrade. I know this is a short notice before the year-end, but if you have a recent version, the upgrade should go seamless.

This is a security upgrade that should protect your site against Cross-site Scripting vulnerabilities (XSS). I know it has been not too long ago, since WordPress came with a major release 3.0. Usually following a major release come multiple smaller release fixes to bring the major release to a stable state.

Remember to have a backup first and then simply go to you dashboard and click on the link to update.

wordpress dashboard upgrade note

Regards.